ros-melodic-rtabmap

Build Status: FAILURE     Last Build Date: 19.2.2021 00:15

Build Output
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
error: command failed to execute correctly
error: command failed to execute correctly
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 124 0 124 0 0 725 0 --:--:-- --:--:-- --:--:-- 725

100 5841k 0 5841k 0 0 7788k 0 --:--:-- --:--:-- --:--:-- 7788k
100 19.1M 0 19.1M 0 0 11.0M 0 --:--:-- 0:00:01 --:--:-- 13.7M
ros-melodic-rtabmap-0.20.7.tar.gz ... Passed
CMake Deprecation Warning at CMakeLists.txt:3 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at CMakeLists.txt:67 (cmake_policy):
The OLD behavior for policy CMP0043 will be removed from a future version
of CMake.

The cmake-policies(7) manual explains that the OLD behaviors of all
policies are deprecated and that a policy should be set to OLD only under
specific short-term circumstances. Projects should be ported to the NEW
behavior and not rely on setting a policy to OLD.


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning at /usr/share/cmake-3.19/Modules/FindBoost.cmake:1204 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1326 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.19/Modules/FindBoost.cmake:1935 (_Boost_MISSING_DEPENDENCIES)
/usr/share/pcl-1.11/PCLConfig.cmake:131 (find_package)
/usr/share/pcl-1.11/PCLConfig.cmake:311 (find_boost)
/usr/share/pcl-1.11/PCLConfig.cmake:546 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)


CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (libusb-1.0)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:288 (find_package_handle_standard_args)
/usr/share/pcl-1.11/PCLConfig.cmake:335 (find_libusb)
/usr/share/pcl-1.11/PCLConfig.cmake:543 (find_external_library)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_COMMON)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_OCTREE)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_IO)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_KDTREE)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_SEARCH)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_SURFACE) does not match the name of the calling package (PCL). This
can lead to problems in calling code that expects `find_package` result
variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_FILTERS) does not match the name of the calling package (PCL). This
can lead to problems in calling code that expects `find_package` result
variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_2D)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:614 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_FEATURES) does not match the name of the calling package (PCL). This
can lead to problems in calling code that expects `find_package` result
variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_REGISTRATION) does not match the name of the calling package (PCL).
This can lead to problems in calling code that expects `find_package`
result variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_SAMPLE_CONSENSUS) does not match the name of the calling package
(PCL). This can lead to problems in calling code that expects
`find_package` result variables (e.g., `_FOUND`) to follow a certain
pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_GEOMETRY) does not match the name of the calling package (PCL). This
can lead to problems in calling code that expects `find_package` result
variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:614 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (PCL_ML)
does not match the name of the calling package (PCL). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_SEGMENTATION) does not match the name of the calling package (PCL).
This can lead to problems in calling code that expects `find_package`
result variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args`
(PCL_VISUALIZATION) does not match the name of the calling package (PCL).
This can lead to problems in calling code that expects `find_package`
result variables (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/share/pcl-1.11/PCLConfig.cmake:611 (find_package_handle_standard_args)
CMakeLists.txt:213 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (OpenMP_C)
does not match the name of the calling package (OpenMP). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/lib/cmake/vtk-8.2/vtkm/FindOpenMP.cmake:485 (find_package_handle_standard_args)
CMakeLists.txt:246 (find_package)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (OpenMP_CXX)
does not match the name of the calling package (OpenMP). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
/usr/lib/cmake/vtk-8.2/vtkm/FindOpenMP.cmake:485 (find_package_handle_standard_args)
CMakeLists.txt:246 (find_package)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning at /usr/lib64/cmake/Qt5/Qt5Config.cmake:39 (message):
Failed to find Qt5 component "Svg" config file at
"/usr/lib64/cmake/Qt5Svg/Qt5SvgConfig.cmake"
Call Stack (most recent call first):
CMakeLists.txt:283 (FIND_PACKAGE)


CMake Warning (dev) at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:426 (message):
The package name passed to `find_package_handle_standard_args` (CSPARSE)
does not match the name of the calling package (G2O). This can lead to
problems in calling code that expects `find_package` result variables
(e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
cmake_modules/FindG2O.cmake:8 (find_package_handle_standard_args)
CMakeLists.txt:402 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/lib64/cmake/Qt5Core/Qt5CoreMacros.cmake:44 (message):
qt5_use_modules is not part of the official API, and might be removed in Qt
6.
Call Stack (most recent call first):
/usr/lib64/cmake/Qt5Core/Qt5CoreMacros.cmake:431 (_qt5_warn_deprecated)
guilib/src/CMakeLists.txt:212 (QT5_USE_MODULES)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/lib64/cmake/Qt5Core/Qt5CoreMacros.cmake:44 (message):
qt5_use_modules is not part of the official API, and might be removed in Qt
6.
Call Stack (most recent call first):
/usr/lib64/cmake/Qt5Core/Qt5CoreMacros.cmake:431 (_qt5_warn_deprecated)
app/src/CMakeLists.txt:80 (QT5_USE_MODULES)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Deprecation Warning at tools/KittiDataset/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at tools/RgbdDataset/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at tools/EurocDataset/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at tools/Report/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at examples/BOWMapping/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at examples/RGBDMapping/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at examples/WifiMapping/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at examples/NoEventsExample/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Warning:
Manually-specified variables were not used by the project:

CATKIN_BUILD_BINARY_PACKAGE
PYTHON_EXECUTABLE
PYTHON_LIBRARY
SETUPTOOLS_DEB_LAYOUT


In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22,
from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23,
from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14,
from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42,
from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25,
from /usr/include/boost/smart_ptr/shared_ptr.hpp:29,
from /usr/include/boost/property_map/vector_property_map.hpp:14,
from /usr/include/boost/property_map/property_map.hpp:602,
from /usr/include/boost/graph/adjacency_list.hpp:27,
from /usr/include/pcl-1.11/pcl/octree/boost.h:47,
from /usr/include/pcl-1.11/pcl/octree/octree_pointcloud_adjacency.h:42,
from /usr/include/pcl-1.11/pcl/octree/octree.h:45,
from /build/src/rtabmap-0.20.7/corelib/src/pcl18/surface/texture_mapping.h:46,
from /build/src/rtabmap-0.20.7/corelib/src/util3d_surface.cpp:48:
/usr/include/boost/detail/iterator.hpp:13:1: note: ‘#pragma message: This header is deprecated. Use <iterator> instead.’
13 | BOOST_HEADER_DEPRECATED("<iterator>")
| ^~~~~~~~~~~~~~~~~~~~~~~
In file included from /build/src/rtabmap-0.20.7/corelib/src/rtflann/util/params.h:33,
from /build/src/rtabmap-0.20.7/corelib/src/rtflann/flann.hpp:42,
from /build/src/rtabmap-0.20.7/corelib/src/RegistrationVis.cpp:51:
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h: In member function ‘virtual void rtflann::anyimpl::big_any_policy<T>::static_delete(void**)’:
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h:81:9: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
81 | if (* x) delete (* reinterpret_cast<T**>(x)); *x = NULL;
| ^~
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h:81:55: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘if’
81 | if (* x) delete (* reinterpret_cast<T**>(x)); *x = NULL;
| ^
/build/src/rtabmap-0.20.7/corelib/src/odometry/OdometryMono.cpp: In member function ‘virtual rtabmap::Transform rtabmap::OdometryMono::computeTransform(rtabmap::SensorData&, const rtabmap::Transform&, rtabmap::OdometryInfo*)’:
/build/src/rtabmap-0.20.7/corelib/src/odometry/OdometryMono.cpp:208:28: warning: ‘void rtabmap::SensorData::setImageRaw(const cv::Mat&)’ is deprecated: Use setRGBDImage() or setStereoImage() with clearNotUpdated=false or removeRawData() instead. To be backward compatible, this function doesn't clear compressed data. [-Wdeprecated-declarations]
208 | data.setImageRaw(newFrame);
| ^
In file included from /build/src/rtabmap-0.20.7/corelib/src/../include/rtabmap/core/Odometry.h:31,
from /build/src/rtabmap-0.20.7/corelib/src/../include/rtabmap/core/odometry/OdometryMono.h:31,
from /build/src/rtabmap-0.20.7/corelib/src/odometry/OdometryMono.cpp:28:
/build/src/rtabmap-0.20.7/corelib/src/../include/rtabmap/core/SensorData.h:192:26: note: declared here
192 | RTABMAP_DEPRECATED(void setImageRaw(const cv::Mat & image), "Use setRGBDImage() or setStereoImage() with clearNotUpdated=false or removeRawData() instead. To be backward compatible, this function doesn't clear compressed data.");
| ^~~~~~~~~~~
/build/src/rtabmap-0.20.7/corelib/src/../include/rtabmap/core/RtabmapExp.h:42:39: note: in definition of macro ‘RTABMAP_DEPRECATED’
42 | #define RTABMAP_DEPRECATED(func, msg) func __attribute__ ((deprecated(msg)))
| ^~~~
In file included from /build/src/rtabmap-0.20.7/corelib/src/rtflann/util/params.h:33,
from /build/src/rtabmap-0.20.7/corelib/src/rtflann/flann.hpp:42,
from /build/src/rtabmap-0.20.7/corelib/src/FlannIndex.cpp:31:
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h: In member function ‘virtual void rtflann::anyimpl::big_any_policy<T>::static_delete(void**)’:
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h:81:9: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
81 | if (* x) delete (* reinterpret_cast<T**>(x)); *x = NULL;
| ^~
/build/src/rtabmap-0.20.7/corelib/src/rtflann/util/any.h:81:55: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘if’
81 | if (* x) delete (* reinterpret_cast<T**>(x)); *x = NULL;
| ^
/usr/bin/uic: /usr/lib/libc.so.6: version `GLIBC_2.33' not found (required by /usr/lib/libQt5Core.so.5)
make[2]: *** [guilib/src/CMakeFiles/rtabmap_gui.dir/build.make:213: guilib/src/ui_preferencesDialog.h] Error 1
make[1]: *** [CMakeFiles/Makefile2:940: guilib/src/CMakeFiles/rtabmap_gui.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:171: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
No packages were built!
   
Git push to AUR Output
There is no aurpush output available.